Powerpack 2


#141

Strange behavior with PowerPack tool (Powerpack Settingsversion 2.3.4) of Piotr in Firefox in macOS High Sierra … what plugin i tried they all not worked

  • PowerPack Addon specially for FireFox
  • Tampermonkey
  • Greasemonkey

When i used Chrome same macOS it worked

What causing this

Please help me to understand


#142

Sorry, no idea, I also have High Sierra, powerpack works for me without any problems in Firefox 57 + tampermonkey


#143

Strange same settings on my MacMini it’s works now in Firefox, maybe a little bug


#144

Hi! Would it be possible to get a popup when hovering over an internal link?
I am think about something along the lines of Wikiwand’s popups.

Wikiwand popup / mockup:


Hover over popup for internal links
#145

This would be really awesome. Dynalist + powerpack2 have become my organizational center, and it would be great to have this also available on iOS. Is adding an option for external user scripts anywhere on your roadmap right now?


#146

Awesome extension. Is the (unobfuscated) source code available online by any chance? Maybe on GitHub or such?


#147

Not on our roadmap right now, sorry. It’s too big for a feature request, since we’re imagining an entire plugin system. Managing the JS code by hand would be too messy, unfortunately.

But yes it would be really cool if the script were available on all platforms!


#148

I completely understand. I guess some of the core functionality of powerpack2 that I find useful (in particular the agenda view) can be somehow implemented externally once the API is there.

Anyway, keep up the great work! (and many thanks to @Piotr for the awesome extension!)


#149

I’m a new user and don’t know how to use/install powerpack? I couldn’t find any guide either. that Guides and examples link is not useful for new users.


#150

You need to install Tampermonkey on whatever browser of your choice.

Install Powerpack 2.

Refresh Dynalist in the browser and see this guide for Powerpack features.


#151

Thanks for the amazing work, Piotr! This is definitely awesome and makes Dynalist more appealing!! :smiley:


#152

When I try to install from GreasyFork, Chrome pops up a message saying “Apps, extensions and user scripts cannot be installed from this website.” Any idea why this is happening and how to deal with it?


#153

You can manually copy the code.


#154

Seems lots of useful stuff, but hard to understand parts of the documentation. Maybe because I’m new to Dynalist. I have installed it, and managed to use it to sort a list. Still things I don’t get. From the top:

Features. Agenda. Icons on top of agenda pane:

Okay you lost me already. What is an agenda? Where is this agenda pane? I found the Powerpack Settings and made Agenda (whatever that means) active.


#155

@Piotr Really cool tool, thanks for your hard work with this. Have you thought about adding your code to GitHub, making it a little more accessible for extension?

Thanks,
Chris


#156

I have the source code from piotr, but he wanted to keep it closed source though from what I remember. Its written in typescript + webpack

The tamperscript file is just the one minified file created by webpack


Alphabetize
#157

You may not turn on the extension.

After you open the example link above and copy it to your dynalist, you can see a flash icon at the top left corner in your browser window . Click the flash icon, turn on the feature you want, close the setting window.

You should see the effect.


#158

I finally have a little bit more time and yesterday started to working on PP 3. Opening links (external, internal, docs, bookmarks, tags, nodes zooms) in resizable, minimizable, customizable popups (with ability to work with multiple popups at the same time) already implemented. Now I will do the same with top, bottom, left, right panels, and I think I will publish this if someone wants to experiment. Oh, and PP 3 creates and uses Dynalist document as a database, so no more need to import/export settings between browsers. This also means endless possibilities. Spaced repetition, reminders, tables, custom attributes for nodes, node aliases, connections between nodes and other crazy stuff may be coming pretty soon, who knows…


#159

:tada:


#160

I’ll be happy to test when you are ready, thanks.