URLs should not be automatically converted

Steps to reproduce

I paste a list of URLs into Dynalist.

When I select the list and copy it, I get markdown code around each URL.

No way to remove it but manually. Even export shows markdown.

Expected result

If I paste something (e.g. URL), keep the source unchanged. Convert the URL to a clickable link in the interface, but allow users to export a clean list of URLs.

Actual result

URLs with markdown around them.


Web, Chrome, Mac

Additional information

Additional comments

If you copy a clean URL (e.g. from the address bar of a browser), it will paste as a clean URL.

If what you copied is a clickable link, the HTML is copied instead and it will pasted as the Markdown formatted link. I think that’s the expected behavior. Just like when you copy bold, you get bold pasted.

The quickest workaround, if you don’t want formats to be pasted, is to copy it into a basic text editor first and copy again to Dynalist.

Oh, my mistake, it seems that the source of URLs I was using did provide HTML links instead of plain text URL.

No worries, you could always use the “Copy link address” option in the right click menu to get the plain text link of the URL.

Cheers! And closing this.

This is not true on Chrome (at least on Linux). If you copy from the address bar it will paste into Dynalist as markdown. It might be that Chrome has now made their links “unclean” and they could technically be blamed, but I think the solution is not to paste markdown.

There is a duplicate issue where people are continuing to express frustration with this: URLs recently started pasting as full markdown with the url cloned in the title area too

IMO this bug should be re-opened because pasting a markdown link from a browser address bar is worse than failing to paste markdown if you copy a clickable link.

1 Like

Thank you for linking to the other issue. I came in to report this issue, and glad to see someone has already done it. I will voice support in the other thread.