Unresponsive, slow, & inefficient

Hey Dynalist team. I’ve been an avid Pro user for a few years now and love what Dynalist has allowed for me in that time both personally and professionally. But over the last 6 to 8 months, Dynalist has become so laggy and slow that it’s barely usable.

I use Dynalist to take notes for the calls I conduct for work - of which I take a lot - so there’s a lot of content, but just text. I am not a power user, in the sense that I probably utilize about 5% of the capabilities that Dynalist offers. I don’t use calendar syncing, colors, sorting, tags, pictures, advanced CSS, etc. I use it as a bulleting note taking platform and that’s it. And when I had a small amount of content, it was a dream. But now it’s a nightmare.

I’ll often type and text doesn’t appear for several seconds. I’ll try to navigate with the arrow keys and my cursor disappears. I’ll try to highlight text and 50% of the time, it does so, the other 50% it just stops doing anything until I click with my mouse. It’s essentially unusable for how I used to use Dynalist, and it sucks because I love the product otherwise. I do use the spellchecking option, but hope that’s not the problem.

This happens whether in the browser, or on the desktop app. I run a 2017 MacBook Pro, 2.3 GHz Dual-Core Intel Core i5 with 8 GB 2133 MHz LPDDR3 on version 10.15.2 of Catalina OSX. If it’s in a browser, it’s Chrome (updated to the latest version always). My Dynalist is “currently running Dynalist 1.3.2. Dynalist is up to date.” No 3rd party scripts, no actual scripts at all. Just text and bullet trees.

I’d love to remain a user, but it’s no longer serving its purpose, which is to type in real time. Any help or suggestions would be much appreciated.

1 Like

Hmm that seems quite weird, maybe it’s something under your account, or my other guess is something related to Chrome/chromium.

Would you be able to try Dynalist on Firefox and tell me if it lags just as much, or behaves differently? I’ve heard there’s some kind of performance issue with Chrome under specific circumstances (that happens with Dynalist) which could be causing your issue.

1 Like

I can try on Firefox, but it happens with the desktop app, as well (unless the desktop app is just a chrome app of sorts?).

That’s correct, the desktop app runs on Electron, which uses Chromium under its hoods to power the interface. Chromium is the engine that powers Chrome.

At the risk of awakening this old conversation when a newer one might exist …

This page was very helpful for me. One of my new Dynalist documents is growing quickly and has become very laggy for typing, practically unbearable. This is on Mac Catalina & Chrome (with only a couple extensions). Also, I’d been needing to press command-F twice to activate the Search box.

Switching to using Firefox for my Dynalist work solved both problems for me. Thanks!

1 Like

Glad it’s solved.

If you’re still curious whats going on, you can see the memory footprint and cpu utilization of the dynalist tab in Chrome by going to it’s task manager. If your computer runs out of RAM it starts swapping things stored in RAM to the hard drive which is slow as molasses. Usually Chrome just crashes the tab with an Aw Snap error before that happens though. Chrome does has a reputation for being a RAM eater.