Pressing Enter does not create a new bullet

Steps to reproduce

Create a bulleted item
Press Enter

Expected result

A second bulleted item under the first

Actual result

Cursor appears in the second line of the first item, without a bullet

Environment

Windows 10 v1803 Build 17134.885
Dynalist Pro (desktop)


Additional information

Closing and reopening Dynalist fixes the problem, but if I leave Dynalist open, it will happen again eventually.


Additional comments

Screenshot to show the gray formatting bar:

Hi Pam, fellow user here. Does the cursor go to the note line (small text, as though you had pressed Shift-Enter), or another title line (large text, as though you had pressed Ctrl-Shift-Enter)?

I ask because I’ve found that sometimes the Shift and/or Ctrl keys can become “stuck” in Windows, and in Electron apps such as Dynalist. I find tapping Shift or Control a few times usually “un-sticks” the key and allows me to use the app normally again.

I’ve encountered something like this as well in Chrome on macOS or in the iOS app, I found refreshing the tab fixed the problem. Can’t reliably reproduce, but I know it happened at least twice…

Thanks, Craig. I tried tapping Shift and tapping Control at various times when this has happened, and it hasn’t fixed the problem.

The cursor does not go to the note line. It acts like a second line of the original bulleted line.

So I just encountered it again, and tried the online version (using Chrome). The problem does not occur. I switch screens back to the Windows app, and still the same issue.

Ah, so it’s just in the desktop app. Sounds like it might be a bug then.