Possibility to lock documents or code segments?

answered

#1

Good Day Everybody,

I really love dynalist. But there’s one thing that’s holding me back from further personal adoption. I keep a lot of technical notes such as code snippets and commands to run in the terminal. I usually mark code snippets with the backward ticks. But when I go to copy the code snippets I click to copy and I move into edit mode where I see a command like so `useradd tacoguy`. I then have to fight with the backticks. The solution thus far is to just not use code segments but then the document looks worse and they aren’t as distinguishable. Especially for commands that write more like an English sentence.

Is there anyway to get around this or to even better lock the documents kinda like a Google doc on mobile where you have to click a button to modify.

Thanks so much


#2

Hi @TacoGuy,

The good news is that the mobile version has a Lock Mode where you can’t edit stuff. The bad news is that it’s not available on web/desktop unless you resize or zoom in enough to trigger the mobile layout. Even in that case from my testing it doesn’t work well enough for web/desktop since it’s designed for mobile.

Maybe we can port that over and improve it for web/desktop. Sorry for the inconveniences for now!

P.S. Love :taco: as well :slight_smile:


#3

Thanks for the reply Erica. I think it would be a great feature. Maybe an option in settings.


#4

One more thing I noticed was that while you can lock the documents on mobile. You are blocked from copying content from the locked document.

If the feature was to be enabled on the main website, that which I would still appreciate. Copying would be critical for most people I think.

Thanks so much Erica.


#5

I think you can still select text. Do you mean you can’t copy the selected content in locked documents?


#6

Yeah it seems when it’s locked you can’t select and thus can’t copy. This is on android.


#7

Ok, that seems like a bug that needs to be fixed. Lock Mode is for avoiding activating the keyboard and prevent editing, but you should still be able to start selecting by doing a long press.

We have tracked this bug on our todo list, and will fix it as soon as we can! Thanks again for letting us know. I’ll update here when it’s fixed :slight_smile:


#8

Hi Erica, I was curious if you thought the new CSS option for pro members could help with my original issue. To go over it again my goal is to lock documents but really I just don’t want code segments to expand open with a click when you go to copy them.

It makes sense for them to expand into backtick syntax when one singles clicks. But if I go to select some text with a click and a drag. Maybe there’s a way to not make it expand.

This is kinda holding back my use of dynalist since I use a lot of code segments. Needing to work around the backticks every time is a pain and is dangerous.

So I was curious if the new CSS feature could be helpful at all?


#9

Technically, it should be doable.

The question is how do you plan to toggle it? For example, let’s say with a piece of CSS, your code blocks are “locked” now. How do you release the lock when it’s time to edit them?


#10

Hi Erica, Thanks for responding. That’s a good question. I’m not sure how it would happen. I guess I was hoping there was a way to differentiate between a double click and click and drag, vs a single click to edit. I’m not a web programmer so to me this is all kinda foreign.


#11

Brand new to Dynalist. Have used workflowy forever, just wanted to add my 2¢
You need to be able to lock outlines
Yes this doesn’t apply to many, my phone has lots of locks, my home computers are in a secure area, but if I leave my computer logged in at work while I step away for a few minutes, anyone could see what I was working on

Thanks


#12

am: if you are using Windows, press Win+L before stepping away for a few minutes.

Erica:

This fix you proposed quickly implementing in March never happened?

The lock mode in iphone behaves weird. I can select lines but not words as there is no cursor. It’s also extremely difficult to select lines. I feel like the sensitive area of a node’s line is to narrow. where it ought to be that long-pressing anywhere onscreen selects a line near my finger, in fact I always have to try 3 or 4 times to get select to happen. Very frustrating.

EDIT: scratch frustrating. Insert unusable. Select anything while edit-locked takes me a random time between 1 and 60 seconds.


#13

Yes I am using windows at work, but we are on a network that allows anyone to unlock the computer that works at our location


#14

I solved it! It seems the issue is that the text region overlays the line region. You can pick the line if you tap the tiny sliver between two text elements. Possible, but practically impossible. OR I just discovered you can tap the left margin. This is relatively easy and makes it possible to select a row in lock mode.

That is awesome. Makes rearranging a Dynalist easy, and eliminates the accidentally typing junk because the keyboard is not on any more. Only thing I wish is an extra 1em of space on the left because it’s easy to accidentally tap a dot.


#15

Yeah, that’s what I do as well. When you lock your computer, everything is locked.

Sorry about that… Glad to know you figured out a way to select things though!

I do see that the margin is a bit small for our thumbs, it’s easier to tap on but still not 100%. I think there was a tradeoff between how wide the indentation (i.e. left margin) is and how much content can fit on the screen. With less width, each line can fit few words and that makes reading not as efficient, as in you need to scroll for longer to read the same amount of text… Tough decisions…