[Offline mode] Document gone after turning on and off sharing in offline mode

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

  • Turn on offline mode
  • Turn on sharing for a document
  • Turn off sharing for a document
  • Document is gone

Expected result

What do you expect to see after carrying out the steps above?

  • No option to share a document when in offline mode
    Or
  • Turn on sharing for a document
  • Turn off sharing for a document
  • Document is still available

Actual result

Instead of the expected result, what happened?

  • Turn on offline mode
  • Turn on sharing for a document
  • Turn off sharing for a document
  • Document is gone

Environment

Which operating system are you using? MacOS
Which browser are you using? Electron app?
If you’re using a desktop or mobile app, what’s the version number of Dynalist? Don’t know where to find this.
Are you using any third-party scripts for Dynalist, e.g. PowerPack? Nope.


Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.


Additional comments

Same. Those steps reproduce the bug for me too.
Warning - do no try this on a document you care about.
Don’t worry, I tried it on a test document.

Document was in the sidebar, but after those steps, it only opened the “No document is open” page. Shared it again, and document disappeared completely, never to be seen again.

So, did you lose an important document?

I see my document is still on my hard drive…it’s just not visible thru the dynalist app…

/Users/bigchungus/Library/Application Support/Dynalist/dynalist/data/XXXXXXXXXXXX/document-~XXXXXXXXXXXX.data

UPDATE: killing the dynalist app and reopening it brought the doc back. Try that @Sander

Hmmm good catch, I guess sharing options shouldn’t do anything for documents in offline mode. Will fix soon.

Nothing is lost, I was just testing the offline option and this happened. I’m happy that Shida will fix this soon.