Notes field doesn't accept text, jumps to beginning of parent line

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

select item
shift-return to create note
cursor moves to note field
paste clipboard

Expected result

What do you expect to see after carrying out the steps above?

clipboard contents pasted into note

Actual result

Instead of the expected result, what happened?

clipboard contents appended to beginning of parent line
note field is unresponsive, not able to delete blank note
shift-return just adds a line to the existing rogue note
sometimes, clipboard contents paste into the field, but in the same format as the parent, and again, deleting just the note is not possible - the delete operates as if the cursor was at the beginning of the parent line
with cursor at end of parent line, pressing return creates a new item with the pasted false note underneath it.
so the note is a rogue one…


Which operating system are you using? Which browser are you using? If you’re using a desktop or mobile app, what’s the version number of Dynalist?

mac os latest, dynalist app latest

Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.

Additional comments

my dynalist opml file is 3.5MB

Thanks for the report!

That’s impressive. Have you tried in any other smaller files (or maybe a test file)? I tried to replicate it but what I copied seems to paste fine into the note field.

Same thing happens in a new document Erica.