Linux client destroys data

Steps to reproduce

I don’t know any way to reproduce this bug.

Expected result

When entering and saving lists, I expect:

  • software to close correctly after save
  • restart then display all lists
  • all lists to be synced with the web based version

Actual result

  • couldn’t close the client windows, had to kill it. All other features worked fine, and I have been working on it for half the afternoon.
  • 90% of the lists disapeared, wasting 3 hours of work. 2 files misteriously are here and up to date. This is despite the fact that I saved regularly, and that the client sync indicator displayed the sync animation, then stated “saved” every time.
  • web based version has none of the files I have locally

Environment

Which operating system are you using? Ubuntu 16.04
Which browser are you using? Epiphany
If you’re using a desktop or mobile app, what’s the version number of Dynalist? Desktop client version is 1.2.2.
Are you using any third-party scripts for Dynalist, e.g. PowerPack? No. I discovered your software today, and I just freshly installed it.


Additional information

Log files in /home/user/.config/Dynalist/dynalist don’t reveal any error.

Directory /home/user/.config/Dynalist/dynalist/data/Mhc_IAh2e2LgS9QNQ9Ubq4-W seems to contains some JSON data of the lists I created, even things from the ones I lost. So the data may still be here, but only partially displayed, and not synced. I have no way to be sure or to know why.


Additional comments

I wish to help you to solve this bug, but I’d appreciate if you could give me a procedure to attempt recovering the data from the JSON files in /home/user/.config/Dynalist/dynalist/data/Mhc_IAh2e2LgS9QNQ9Ubq4-W. Even if I have to write a JS/python script to do so. I really don’t want to type all that again.

When you open the desktop app again, it doesn’t have anything you worked on today, correct?
Also - when you restart the desktop app, does it show a different version or does it still show 1.2.2?

Lastly about your data: we can speak about recovering it where if you’re comfortable sending us the data folder via email (support@dynalist.io) we can try to convert it to something usable.

1 Like

When I open the desktop data again, it shows 3 of the files I created, up to date, containing the latest content I entered. All other file don’t appear.

Restarting the app still show 1.2.2 yes.

Ok, I’ll send you the data folder by email. Thank you.

1 Like

Your colleague managed to get most of my data back. Thanks a lot. WIth such a good service, I’m very confident in taking a the pro plan.

Too bad I can’t help you find out what happened. Unless you want more information, you can close this ticket.

Really sorry about that. Hopefully it won’t happen again. If it does, let us know and we’ll conduct a deeper investigation.

Thanks!