Item order sometimes changes after syncing


Since this one occurrence, I couldn’t reproduce this either. All Dynalist instances are working perfectly reliable. You shouldn’t waste too much time on this, until we have more info.

It’s good to know that the contents are purposefully synced independently from the location and ordering. I was just confused that the ordering of the complete list was not synced at first; then suddenly it has been synced normally.

I have one more observation: during the time where the standalone Dynalist disagreed with the on-line ordering, it produced several log files in ~/.config/Dynalist/dynalist/:

1297 Nov 21 11:30 dynalist-2017-11-21-11-15-49.log 1879 Nov 21 12:10 dynalist-2017-11-21-11-40-32.log 595 Nov 21 13:40 dynalist-2017-11-21-13-35-11.log 4215 Nov 21 15:12 dynalist-2017-11-21-13-47-53.log 4712 Nov 21 11:12 dynalist-2017-11-21-9-47-16.log

The times are all CET.

They all contain among other messages the following error message:
[Updater] [Updater] Failed to apply updates. { Error: socket hang up at TLSSocket.onHangUp (_tls_wrap.js:1092:19) at TLSSocket.g (events.js:286:16) at emitNone (events.js:91:20) at TLSSocket.emit (events.js:185:7) at endReadableNT (_stream_readable.js:974:12) at _combinedTickCallback (internal/process/next_tick.js:74:11) at process._tickCallback (internal/process/next_tick.js:98:9) code: 'ECONNRESET' }

Is there a possibility that the (failing) update of the Dynalist standalone App is interfering with the syncing of the lists?


Wow, @Viktor_Papara… you rock. Great detective work.

If I see this again on my Linux installation, I’ll check for logs. @Erica where can I look for logs on an android device, which is where I usually see it?

Regarding the severity of this… it doesn’t happen often, but when it does it is critical enough that it makes the use of platform specific clients (Android in particular) unusable for me for some of the use cases that I have.


gently throws the question to @Shida

Yes, I definitely agree order is very important. I just wish we had consistent repro steps so we can investigate and fix this!


As far as I know the logs are completely independent of the actual sync itself. The logs are written by the updater module that runs in the electron main process, while the sync happens in the web/renderer process and any logs in there are transient to the session and only available through the dev console.


Ok, I may have something useful here. I was working with a file that I have, and I created a list by pasting in some text. Each line became, as usual, one item. I then proceeded to add sub-items, etc. When I looked at this list in the Android client, the last two items had switched positions.

So I edited them in the web client, and checked how they synced and the changes were synced but they remained out of order. Ok. So I made a complete copy of the file. In the new file, the items were in the correct order on the Android client.

Next, I tried syncing that same problematic file with another Android device and wala! the items remained out of order.

So what do we learn here? Something about that particular list is consistently not getting synced with the correct order. I edited out the stuff in there that I did not care to share so that I could make the file available to you for troubleshooting.

Steps to reproduce (apparently consistently):

  1. Look at the file in a web client. There are two that are labeled “out of order 1” and “out of order 2”. On the web client, you will notice that they are 1 then 2.
  2. Look at the file using the Android client. Items 1 and 2 should be switched positions.

Tagging you @Erica and @Shida (I know you guys have a lot to do so just making sure this answer floats up on the radar that we may now have reproducible steps with this example file). :slight_smile:


Hey, just checking on this to make sure it’s still on the radar. :slight_smile: Was anyone able to reproduce it using the info above?


Hey guys, it’s been almost a month since I was able to provide steps to reproduce this. Any news? I just want to make sure it hasn’t fallen between the cracks. :slight_smile:


Sorry, @PJ_Zoulin. I can’t reproduce the out-of-ordering in your document. :slight_frown:

When I open it via web client, I see the correct ordering as you do.
And the only way to open it in android and linux standalone apps is to “Copy to my Dynalist”; and then both my android and linux apps show the correct ordering.
But this makes kind of sense because this operation makes a copy of your file and you said that if you make a copy, the wrong ordering disappears.

I’m also unable to reproduce this error by pasting text with newlines to produce several bullets at once.

So, do you see this file still with wrong ordering on your android app? Even after several weeks?

If yes, and if you want to investigate further, I have the following suggestion. You can install the Dynalist linux app (or maybe the windows app) and look if this app also shows the wrong ordering.
If yes, you could investigate the config files of Dynalist. It stores the documents in ~/.config/Dynalist/dynalist/data/[some gibberish]/. Here, your dynalist documents are stored as text files with the ending “.data” but they are perfectly readable with a text editor.

Those files contain a lot of metadata, which makes them messy to read. But you could compare this meta-rich file of the out-of-order file and its correct-order copy. Maybe a diff would shed some light on the problem.


Hey @Viktor_Papara , yes I still see it in the Android app for this test file. I was already using the linux app before and in it the list shows in the correct order. The only place where I can positively see it out of order is the Android app. I have the Android app installed on a second device and I checked there too, same thing. On the Android app it shows out of order.

Not sure if maybe @Erica or @Shida could work some magic to let them directly see it in the Android app? If so, it seems that the issue should be reproducible.


Sorry for the late reply!

One possible way is to share the document with me ( in addition to sharing it publicly. That way after accepting the invite I will see it among my documents and thus I can check out the orders on my Android app.


This is what I see on my Android app:

Looks like the order is right?


Wow, it sure does. I dunno. I tried again on a third android device (chromebook using Android app) and on that one it looks good. On the original two devices, “Out of place” 1 and 2 are still switched.

Who knows. Just scratch it off for now I guess and if I can reproduce it another time with a brand new one we’ll try again or something.


Ok, please do!

Thanks again for providing such detailed follow-ups!


Hi team,

Just to let you know I’ve been experiencing the same issue. Namely:

  • mac OS X app showing notes in particular order
  • Mobile web and Desktop web show correct order
  • Mobile app (iOS on iPad and iPhone) are showing incorrect ordering

The solution for me was to delete and re-install the mobile app. This seems a bit overkill though so I was wondering if this method could be reproduced (i.e. force the mobile app to recheck or resync ordering against another source?)




You could also erase the app’s data.

Unfortunately, I just played with iOS 11 and it looks like there’s no way to only delete an app’s data without uninstalling it, which is a little odd since I thought this option should exist. I might be wrong though, not an iOS user myself (this is what convinced me that it probably doesn’t exist on iOS:

As mentioned in that post in MacRumors, you might be able only erase data without uninstalling with the help of third party apps, but that might be an overkill.

Anyway my point is that uninstalling and reinstalling is not necessary, as long as you clear the app data.

Regarding the issue itself, did you notice any patterns, except that it seems to only happen on the mobile apps?


As an android user, I can say that it only seems to happen for me on the mobile app. The mobile web page is fine. It’s not just an Electron thing, because the Linux app is also fine. It is interesting to me that it seems to be happening on both iOS and android.

From what I can determine, it seems to be just a visual effect when it happens. Somehow the syncing puts the items visually in the wrong order. The incorrect order actually change the data and doesn’t seem to sync back and cause an issue with the “real” data on other platforms.

I see this a lot (or at least, a significant occurrence rate), but it usually happens in data that I can’t just share. I took one of those files once and removed everything else to show the issue, but it was a few weeks before anyone was able to look at it and by then it no longer demonstrated the problem.


Data you can’t share general means the local data on your phone, so the issue should go away as you clear the app’s data and it downloads a fresh copy from the server.

I still can’t understand what could possibly result in the data discrepancy in the first place though.


Sorry, when I said “data I can’t share” I meant that I see this in dynalist lists that have information that I can’t just put out there for debugging.

I believe that clearing the data (Android) does cause the next sync to look correct.


Ok, so now we can tell it’s happening on a local device, and will go away if the local cache is cleared.

Now the question is how did it happen in the first place…

So let’s say the items out of place are item A and item B. Item A should appear above B but on your Android phone A appears below B.

If you remember, did you touch (edit or move) these two items on web or Android before you notice they are out of order?


When I notice this, my workflow is usually as follows:

On the web client, I am reading material material in one tab and taking notes in dynalist in another. I sometimes copy material over from where I’m reading it to the list where I am taking notes. After copying over a paragraph, sometimes I manually break it up into chunks and then move bullets around.

After the entire thing is done, sometimes a day or two later I open the Android client and notice the out of order situation. At that point, I haven’t touched any items on the Android client.

I am going to try to see if I can duplicate it again and pare down the list to make it available for sharing so I can get a “clean” case again. As soon as I have something, I’ll post again.