Formatted export should only copy the rendered Markdown, not theme


#1

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

Enable Dark theme

Create any item, for example test markdown item
Copy output from Export → Formatted
Paste e.g. in Pages

Expected result

What do you expect to see after carrying out the steps above?

Pages:

Actual result

Instead of the expected result, what happened?

Pages:

Word:

Environment

Which operating system are you using? Which browser are you using? If you’re using a desktop or mobile app, what’s the version number of Dynalist?

Dynalist for macOS 1.2.0


#2

It’s up to you to paste without formatting with the “merge formatting” option in MS Word.

I tried copying from a dark website (I tried the Discord homepage), and I get this:

The “merge formatting” option fixed it.

So from my understanding it’s a browser default behavior, not a bug.


#3

Ah well, I get what’s the problem. Copying styles apparently is the default behaviour in Chromium but isn’t in Firefox which I’m mainly using, so it struck me off as a bug.

Consider it a feature request then, albeit a very minor priority one :slight_smile: it seems to me that such behaviour is way more sensible in the context of an outliner app, hardly anybody means to copy Dynalist theme with their bullets.


#4

Then it could be that Chromium tries to calculate all the styles so that it will look the same when you copy paste to Word. For example, we didn’t specifically set the background color of those exported items to be black, but Chromium copied it as so because the popup is black… Firefox is smarter at that I think.

With merge formatting or the usage of Ctrl+Shift+V (paste without formatting), I think most problems can be solved. Thanks for the feature request though! :slight_smile: