False Custom Keymap error

Steps to reproduce

  1. Try to set keyboard shortcut

Expected result

No error message

Actual result

Environment

Web app on OS X

Can you take a screenshot of this part of the keymap tab for me please?

Thanks! :smile:

This?

Yeah, so the error says you’re trying to set some shortcut to Cmd+Shift+N but it’s taken by “Toggle notes”. Did I understand something incorrectly?

I was setting the “Toggle notes” shortcut itself. The UX gives me an error about the shortcut I just set for a particular action as conflicting with itself, if that makes sense.

Ah, I think I’ve seen this, but forgot to report it. Essentially, setting the shortcut works as expected, but an error message is sometimes (it didn’t happen when I tried again) given.

I was able to make this happen once and then it got normal. I only see a success message after setting a shortcut.

Heisenbugs… :worried:

1 Like

Got another bug report about this, also on MacOS/Safari.

@Yatharth_Agarwal: were you using Safari too?

I was using Chrome.

I’ll start mentioning my browser in future bug reports.

2 Likes

That would be great, browsers are sometimes very different.

Thanks!!

1 Like

I tried both Chrome and Safari on macOS, but can only reproduce the issue rarely.

From my experiments, it looks like this bug only happens the first time you try it. If you try setting some shortcut again, be it some other shortcut or the same shortcut, it would work.

Can someone confirm my finding? :slight_smile:

I believe that this is the case.

It happened yet again. Did you mean to say that it’s for each key that one tries to set?

1 Like

Yeah, maybe, but only for the first time. If you try again with the same shortcut after seeing the error message, it would work, at least in my case.

Truly weird…

1 Like