Duplicate notes showing after a search is canceled

Steps to reproduce

• enter a character into the search box (a character that is in the note text, not the item text)
• press backspace to delete the character (or click X or esc until the search box closes)
• any notes that have the searched character in them will now be duplicated
• clicking on the note text makes the duplicate disappear. clicking anywhere else will make it appear again

Environment

dynalist web & desktop app (windows 10 pro - version 1607)
• chrome
• firefox portable
• edge

dynalist mobile (android 6.0.1)
• chrome

(internet explorer on windows is working normally, notes are not duplicated)

 

Additional information


going to another document and then returning to the first document removes the duplicate notes.
reloading the page also removes the duplicate notes.

2 Likes

cc: @erica #20charlimit

so is anyone else having the same problem? its been happening for a good few months now so i thought it was strange that there isnt any mention of it here. maybe its been reported on trello? or maybe its just some bug that is only happening on my system?

Can’t reproduce :frowning:

See recorded screen below:

bandicam 2017-01-27 18-38-37-386.avi (215.9 KB)

I tried with my content and couldn’t reproduce it, so I replicated your content and tried again. Still no luck.

I’m showing both checked items and notes.

Am I doing something different?

yes everything looks the same there.

i tried the web version in windows “safe mode” and also tried in a fresh windows install in a virtual machine but the problem was still there

i tried on two different computers as well and got the same results. are there any other things i can check?

Damn, I don’t know. If you’ve tried on multiple computers I’m assuming you’re using the latest version too, so an out of date version is probably not the cause here.

Since you can reproduce on both web and desktop, browser extensions are out of question too.

I’m out of ideas… anyone else can reproduce this?

both of them are up to date yes.

dynalist on internet explorer doesnt have the problem though while the other 3 browsers do, so maybe that might help narrowing it down?

I’m afraid not… we just need one case to make the bug happen. Right now I can’t reproduce what you saw in any browser :frowning:

ive just been doing some more experimenting with this and i noticed the problem doesnt happen if i have notes set to “show”. once i click back to the “1st line” option (which is what i normally have it set to) …the duplicates will be showing. if i select “show” again they disappear.

1 Like

more notes.

i noticed its only happening when the last character in the search box is deleted. (same example as the above image but with more letters)

then there are other cases where i search for a word but when i delete the word fully, only the first character of the word is left highlighted and not the whole word. (see the “n” after searching for “note”)

 

ive also been messing around with tampermonkey and made a script that removes the duplicates by clearing out any “Node-renderedNote” elements that have highlighted text in them.   this happens when the escape key is pressed, or when the X or search icon is clicked in the search bar.

the duplicates still show up when searching, but at least when i find the location im looking for i can just press escape to remove the duplicates instead of having to reload the page.

im not sure if removing them is going to break something elsewhere either but im happy not seeing double for now :smiley:

2 Likes

Thanks Dave! We’ve successfully reproduce the issue as well, but still, thanks a lot for this! Confirmed our reproduction steps as well.

We’ll have this fixed soon, hopefully :slight_smile:

2 Likes

its working great now thanks!

2 Likes

Thanks for confirming! Yes yesterday’s release fixed it :slight_smile:

1 Like