Can't sync in Mac app

Steps to reproduce

My mac app can’t sync to latest contents. Web app is OK instead.
On sync status bar, It’s “saved” instead of “synced” or “syncing now” … It’s always “saved” from some time…

just as below:

I tried to reinstall my app and relog-in my account, it’s now working yet

Do you mean it’s “not working yet” or “now working again”?

Also which country are you in? Even if you have internet, it can say “Saved” instead of “Synced” if your computer cannot reach our server. If that happens, you’ll need to use VPN software, unfortunately :frowning:

Oooo, sorry Erica, it’s NOT working yet. I m in China, but web is ok. And also, i used vpn to try it, still saved.
BTW, is it different server between web and mac app?

Plus, I installed a mac app in my another mac, all are ok.
and in my this mac, I login with another account, all are ok…
Should I clean some cache or anything in my this mac?

No there isn’t.

Could you try just restarting the app, not uninstalling and reinstalling it?

I’m also getting an issue here. Web app works as expected, but the mac app doesn’t sync (and new documents from web aren’t reflected in the Mac app).

I’m definitely connected to the internet (in the US, no vpn or proxy stuff), but the debug console of the app shows OFFLINE ENABLED. There’s also debugging.ts:60 Error: Uncaught TypeError: Cannot read property 'get_server_id' of undefined, which feels related.

So sorry about the late reply!

This part is expected, OFFLINE ENABLED means offline capabilities are working properly, not that no internet is detected, so no need to worry about that part :slight_smile:

@Shida Could you take a look at the debugging.ts:60 Error: Uncaught TypeError: Cannot read property 'get_server_id' of undefined part?

@Erica I’m also having this issue on the windows apps. I’m currently in Thailand but have been for months with no issues. More worryingly my app says “save now” in the corner and won’t seem to save a local copy or let me close the app. This is after I restarted to try and fix the problem that is stated above.

It’s throwing 403 errors every couple of seconds and and “Uncaught TypeError” is thrown when I hit “Save Now” in the corner.

@Shida please take a look, thanks!

Taking a look now. It seems like some kind of small corruption in the local save files or some sort like that which is generating the error. I’ll double check and see how we can restore the saves and make it sync again.

Weirdly our servers aren’t supposed to return 403, even when forbidden or not logged in. I’ll need to see why that’s happening.

Hi, I also have a problem, can’t get the Mac App to sync no matter how many times I delete & reinstall. Works fine on web, and iOS (iPhoneX and iPad Pro), originally reported here, not sure if I need to flag my issue differently or elsewhere?

Hey there, I’m also having a sync issue with the Mac app. Ever since I tried copying a large document and pasting it into an empty doc, I’ve been getting the “Can’t Sync” message.

The error report just has the entire doc I copied in it, which won’t go away (tried uninstalling/reinstalling). Curiously, the desktop app is syncing with my android app (for now). Still, I’d really like to clear the error message and report, if at all possible. Thanks.

Could you back up (export) that large document and then try the following:

  1. Make sure local data are saved (you can export local unsaved changes to OPML or plain text using the “Export” option in the item menu);
  2. Exit the desktop app;
  3. Rename the following folder “data” to “data-backup”
    Windows: %APPDATA%/Dynalist/dynalist/data
    Mac: ~/Library/Application Support/Dynalist/dynalist/data
    Linux: ~/.config/Dynalist/dynalist/data
  4. Restart the app.

That should pull a fresh copy from the server and fix the issue. After that, paste or import the local changes to continue.

Let me know if that fixes it!

Erica, that 100% worked! The app even seems to be slightly faster, too. Thanks for the quick help, y’all are great.

1 Like