Can't find capitalized letters in "parent:" search

fixed

#1

I would like to start by saying I love this feature! Being able to search by attributes of the parent is fantastic. I can now do with hierarchy what I used to have to do with tagging. Thank you very much for implementing it!

In playing around with it, I found an issue:

Steps to reproduce

Create a document that has parent nodes with capital letters, such as:

Let’s say we want to see all of our Active tasks that are ready to be worked on, so we search for parent:Active.

Expected result

We see just the Active nodes and their children.

Actual result

We see no nodes at all. (But see below!)

Environment

Windows 10 Pro version 1803
Google Chrome Version 75.0.3770.100 (Official Build) (64-bit)

Additional information

However, the search does work if we exclude the capital A from the start of the search! If we search for parent:ctive instead we see the results we expect:

Additional comments

Perhaps there is a bug involving toLowerCase() when comparing the search terms to the parent text? Maybe the search term is being lowercased but the parent text is not? (Searching for parent:active doesn’t work either.)


#2

Thanks for catching this!

We have tracked this bug on our todo list, and will fix it as soon as we can! Thanks again for letting us know. I’ll update here when it’s fixed :slight_smile:


#3

This should be fixed in the latest versions (please refresh/reload the app to update), could you please confirm when you have time? Thanks in advance!


#4

It work for me :slight_smile: Thanks for fix.


#5

Confirmed! It works now. Thanks for the fix! :smiley: