Unindent behavior in the middle of a list

closed

#1

Steps to reproduce

(1) Create a list like this:

  • One
  • Two
    • Alpha
    • Bravo
    • Charlie
    • Delta
    • Echo
    • Foxtrot
  • Three
  • Four

(2) Put your cursor in the item “Charlie”
(3) Press shift-tab to unindent

Expected result

  • One
  • Two
    • Alpha
    • Bravo
  • Charlie
    • Delta
    • Echo
    • Foxtrot
  • Three
  • Four

This is the behavior you see in MS Word’s outliner, in Google Tasks, and in any text editor.

Actual result

  • One
  • Two
    • Alpha
    • Bravo
    • Delta
    • Echo
    • Foxtrot
  • Charlie
  • Three
  • Four

Comments

See screencast here.

I can understand the logic behind the existing behavior - we’re putting Charlie in the next higher level of the hierarchy, but we’re not turning its former siblings Delta, Echo, and Foxtrot into its children.

But the proposed behavior feels much more natural - partly because it’s an existing UI pattern. It also preserves the symmetry between tab and shift-tab in that I can indent and unindent a single item without changing its sequential position.


#2

Sorry, but I disagree. This isn’t a bug. Current behaviour is what I would expect. Looking at a few true outliners e.g. Checkvist, Noteliner, and most importantly Workflowy, they operate in the same way as Dynalist. Word and text editors may have outline views but they aren’t outliners. For word processors, the text sequence tends to take priority rather than the logical hierarchy. I can see a use case for what you’re asking e.g. if you’re importing a flat list which is in the right hierarchical sequence but without the hierarchy, but I think that is a niche requirement. Operating in the same way as Workflowy is particularly important as a lot of current and future users will come to Dynalist via that route. I’d suggest you submit a feature request instead.


#3

Thanks, @pottster, yes that’s our initial design.

As requested by many users like you (@Herb_Caudill) though, we’ve added a setting called “Unindent items in-place” in Settings - Preferences - Control. Check that and you should get the behavior you want.

I hope that helps!


#4

Excellent, thanks Erica!