Possibility to lock documents or code segments?

resolved

#1

Good Day Everybody,

I really love dynalist. But there’s one thing that’s holding me back from further personal adoption. I keep a lot of technical notes such as code snippets and commands to run in the terminal. I usually mark code snippets with the backward ticks. But when I go to copy the code snippets I click to copy and I move into edit mode where I see a command like so `useradd tacoguy`. I then have to fight with the backticks. The solution thus far is to just not use code segments but then the document looks worse and they aren’t as distinguishable. Especially for commands that write more like an English sentence.

Is there anyway to get around this or to even better lock the documents kinda like a Google doc on mobile where you have to click a button to modify.

Thanks so much


#2

Hi @TacoGuy,

The good news is that the mobile version has a Lock Mode where you can’t edit stuff. The bad news is that it’s not available on web/desktop unless you resize or zoom in enough to trigger the mobile layout. Even in that case from my testing it doesn’t work well enough for web/desktop since it’s designed for mobile.

Maybe we can port that over and improve it for web/desktop. Sorry for the inconveniences for now!

P.S. Love :taco: as well :slight_smile:


#3

Thanks for the reply Erica. I think it would be a great feature. Maybe an option in settings.


#4

One more thing I noticed was that while you can lock the documents on mobile. You are blocked from copying content from the locked document.

If the feature was to be enabled on the main website, that which I would still appreciate. Copying would be critical for most people I think.

Thanks so much Erica.


#5

I think you can still select text. Do you mean you can’t copy the selected content in locked documents?


#6

Yeah it seems when it’s locked you can’t select and thus can’t copy. This is on android.


#7

Ok, that seems like a bug that needs to be fixed. Lock Mode is for avoiding activating the keyboard and prevent editing, but you should still be able to start selecting by doing a long press.

We have tracked this bug on our todo list, and will fix it as soon as we can! Thanks again for letting us know. I’ll update here when it’s fixed :slight_smile: