(Lovely new) functions slider not appearing on mobile when text is formatted or has date stamp

fixed

#1

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen? The fewer the steps, the better.

Edit a bullet on mobile web which has bold or italic formatting or a date stamp.

Expected result

What do you expect to see after carrying out the steps above?

The (lovely new) functions slider appears.

Actual result

Instead of the expected result, what happened?

The (lovely new) functions slider does not appear.

Environment

Which operating system are you using? Which browser are you using? If you’re using a desktop or mobile app, what’s the version number of Dynalist?

mobile chrome web app.

Additional information

Anything else you think would help our investigation, like a screenshot or a log file? You can drag and drop screenshots to this box. For large amount of text, try putting them into something like Pastebin.


Additional comments


Blackberry PRIV, the perfect dynalist phone
#2

Thanks for the report!

Can’t seem to reproduce the problem on Android Chrome though. Are you on Android Chrome as well?


#3

Yes unfortunately I just reset everything and still have the issue, although it’s oddly inconsistent (literally it will show up about 25% of the time for no obvious reason) so might not show up on brief testing.

Also just to add, the slider doesn’t show up for me when you are in the ‘note’ section of the bullet either - this is 100% of the time so perhaps is a design decision but one does want to use these features when in the note (e.g.add a date) so I hope you might consider changing this.

Here’s some screenshots of the date issue:


#4

Just replicated this issue on a second phone (it does seem to only be half the time or a bit more that it fails, which is odd!)


#5

Yep it’s annoying that it’s not show up when you want to edit an line,.

I tested on my iPhone :eyeglasses: but in my case issue is not is node or task has date or not.

:heart: the function slider BTW :

Cheers
Dimitry


#6

In the second screenshot I don’t see the blinking caret, is it there, just not captured?


#7

Yes it’s definitely there I’m afraid :slight_smile: you can see also the date is in edit mode


#8

Yes I can see that, just making sure something weird is not happening.

I’ll keep testing and see if I can reproduce it…


#9

Hi @Erica, this is still a major issue for me on mobile - I am constantly having to click in and out of items to get the slider to appear (it is very unreliable, sometimes it appears above my keyboard, sometimes not)- I’ve replicated this across three phones, three browsers and several keyboards. Are you able to replicate it?


#10

Rarely and inconsistently. Definitely not as often as how often you see them though.

Do you think it could be related to how quickly you switch between items?


#11

Ah that’s a shame, but good to know it happens to you sometimes (for diagnosis purposes I mean!). Is there any chance of an engineer looking into this at some point?


#12

Both @Shida and I are engineers and we’ve both looked at it. It’s not easy to debug a heisenbug though.

As part of the effort to make mobile apps better we’ll continue investigating this, just saying more clues to repro the issue consistently would be valuable.


#13

Hi @Stephen_Dewitt, sorry for digging this up :grimacing:! We’re cleaning up the bugs and would like to know if the bug is still happening to you? If not we’ll close this bug :slight_smile:


#14

Hi Erica, yes this seems fine to me now, awesome work!! :slight_smile:


#15

Thanks for the kind reply! Closing it :slight_smile: