"is:completed" operator doesn't show results in global search

fixed

#1

Hi.
I’d appreciate help.
When I use the operator “is:completed” for searching in same document, it works.
However, when I press “ctrl+enter” for global search, there is no result listed. Event the completed items that appeared in the document search before didn’t appear in global search output.
How to search for “is:completed” globally?
Thanks!
Carlos


#2

Search for it while having this setting disabled:

I feel like this is a bug though. If you’re searching for normal keywords, these checked items shouldn’t show up. It no longer makes sense for them to not show up after you’ve specifically asked for them with “is:completed”.


#3

Thanks for replying @Erica
After turning on “show checked items”, then “is:completed” works in global search.
If “show checked items” is disabled (unchecked), operator “is:completed” doesn’t work.
It sounds a bug indeed. Once typed “is:completed” explicitly, then the global search output should work in any situation, independent of the setting tweak “show checked items”.


#4

Yeah, so do you mind if I move this to the bug category?


#5

Already moved. Thanks for taking care of this one!


#6

@Carlos: This should be fixed in the latest versions (please refresh/reload the app to update), could you please confirm when you have time? Thanks in advance!


#7

Great, thank you Erica


#8

Thanks for the fix. Everything working properly!