Focus issue with Find

resolved

#1

Steps to reproduce

Press Ctrl+F, type characters to search.

Expected result

Able to press Tab to edit items in the filtered list.

Actual result

I have to press Tab twice to get into edit mode of the list. This should only require one Tab.

Also, two Esc are required to cancel out of search mode while editing.

The first Tab/Esc dismisses the “Search in all documents” popup. Can the popup be turned off?

Environment

Windows 10, Firefox 54, Chrome 59.



#2

First, use Tab once to go to the filter result was never an intended thing, so this is more like feature than a bug. Because Tab controls indentation in Dynalist, we normally don’t assign other actions to it to avoid confusion.

But I guess it’s a convention to jump to things with Tab? We haven’t heard much feedback on this, if you agree please like @Kyle_A’s post so we know.

It only requires one Esc press to close search and restore the cursor position. Is it possible that it’s from a browser extension you installed?


#3

I couldn’t find another keystroke that worked. Enter might be another option, but that also has a function within the list. I think it makes sense for the behavior of Tab/Enter to be based on the context.

Regarding Esc, I restarted Firefox with addins disabled, and it still requires two Esc. Same thing with the Ctrl+O window. Also, most of the time when pressing Enter to choose a document in the Ctrl+O window, it doesn’t go into edit mode of the list (have to press Tab).


#4

I have the same OS (Windows 10) and I tested in both Firebox and Chrome, only one Esc. I think we’d know if two Esc presses are required as that would be really annoying and we would hear about this problem.

Is it possible that the first Esc is intercepted by your system somehow?


#5

I found the problem – the VimFx extension. I disabled that for dynalist.io and it’s working now.


#6

Returning to the original problem, can you fix the issue of having to press Tab twice to edit the list? You said that wasn’t an intended thing – then what is the intended way to do that with the keyboard?


#7

There’s a new setting for that under Settings - Preferences - Advanced.


#8

Thanks.