Does not new API (Send to Inbox) work in UTF-8?

resolved

#1

Steps to reproduce

  1. Post content in UTF-8, using new API (Send to Inbox)
  2. I get {"_code":“Ok”}
  3. The contents will display in garbled text.

Expected result

“テストテスト” → “テストテスト”
“Süß” → “Süß”
“Hello World” → “Hello World”

Actual result

“テストテスト” → “テストテスト”
“Süß” → “Süß”
“This is test” → “This is test”

I reproduced these garbled texts conversion in

  • “UTF-8” → “ISO-8859-1”
  • “UTF-8” → “numerical character references”

Does the API use “ISO-8859-1” or “numerical character references” in that?

I used this garbled text tester.
But, I’m sorry this site written in Japanese.
(http://lab.kiki-verb.com/mojibakeratta/)

Environment

Additional information

Capture from my Inbox
eb329af58428561ecfcb5d274cd474f8


Additional comments

I found that making an API is wonderful.
I reported a bug when I thought I could support this work.
Thank you.


#2

Thank you!

Sounds like we overlooked something here. @Shida: could you take a look please?


#3

Seems like a misconfiguration in our web servers that defaults the request to ISO-8859-1 instead of UTF-8. I’ve made a fix and it should be out in the next few days.

Meanwhile, as a workaround, you can use application/json; charset=utf-8 as your ContentType header to force the encoding to UTF-8.


#4

Thank you very much!

The webhock service by IFTTT doesn’t have options for encodings.
I’ll be waiting for the update!


#5

Cool!

Meanwhile, I’ll move this to the Developer category, so they don’t confuse other users.


#6

@Yusaku_N: should be fixed now, could you please verify?


#7

Unfortunately, the error still happened.

I need call the API with “Content-type: application/json; charset=utf-8” :frowning:


#8

Sorry, there was some issues with the last release. Could you try yet one more time? Sorry! :frowning:


#9

The error was solved. Thank you so much!

Now, I can use the awesome API from my Google Home, Note Widget by IFTTT, and more!


#10

Great! :slight_smile: